Client portal

  • XtendWeb version 4.5-18 and nginx-1.15.1 now available

    July 8, 2018 by Anoop Alias
  • Greetings,

    XtendWeb version 4.5-18 and  nginx-1.15.1 now available 

    Upgrade instruction

    #######################################

    Minimum requirement : cPanel version 72.0.7 or above . Do not upgrade XtendWeb if your cPanel version is lower as this version needs SSL/AutoSSL hooks available only in version 72.0.7 or above . RELEASE/CURRENT channel is fine. STABLE version is still on v70.0.51. So if you are on STABLE channel ,defer upgrading XtendWeb 

    yum --enablerepo=ndeploy upgrade nDeploy nginx-nDeploy*

    systemctl daemon-reload

    /opt/nDeploy/scripts/attempt_autofix.sh

    /opt/nDeploy/scripts/nginx_upgrade_inplace.sh  # do service nginx restart if in-place upgrade fails 

    #############################################


    Whats new?

    1. XtendWeb now uses cPanel SSL/AutoSSL hooks to correctly generate TLS configuration. https://blog.cpanel.com/new-ssl-standard-hooks-for-cpanel-whm-integrators/  . Because the hook does not trigger on certificate delete/uninstall .It is highly recommended to enable the following setting in Tweak settings

    http://i.imgur.com/SlpQfDN.png

    Also read: https://www.theverge.com/2018/2/8/16991254/chrome-not-secure-marked-http-encryption-ssl


    2. Better handling of subdomains like webmail. , cpanel. etc in XtendWeb generated configuration

    3. The latest release of Nginx mainline and other modules for the Nginx binary build 


    If you need any assistance in upgrading, please do not hesitate to open a support ticket 


    NB:

    ##############

    If you are running XtendWeb cluster ,please defer the upgrade as the geoDNS component is scheduled to be changed - https://github.com/AnoopAlias/XtendWeb/issues/350

    If you have a managed service with us, the upgrade will be automatically scheduled and performed from our end .Please ignore this notification

    ###############


    Have a great Weekend

    A U T O M 8 N


Powered by